This will be the first in a series of troubleshooting labs. I will post a topology and the issue I’m seeing. Hopefully you guys will attempt to solve it and post your ideas, questions and solutions in the comments.

We’ll start with a relatively easy one. Today we are having an issue with BGP neighbor relationships not forming.

Here’s our Topology:

Here’s R1′s config:

hostname R1
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 description To R2
 ip address 10.1.1.2 255.255.255.254
!
router bgp 5000
 no synchronization
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 6000
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 10.1.1.3

And R2:

hostname R2
!
ip cef
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 description To R1
 ip address 10.1.1.3 255.255.255.254
!
router bgp 6000
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 5000
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 10.1.1.2

Now some show commands:

R2#sh ip bgp summ
BGP router identifier 2.2.2.2, local AS number 6000
BGP table version is 1, main routing table version 1
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4  5000       0       0        0    0    0 never    Active
 
R1#sh ip bgp summ
BGP router identifier 1.1.1.1, local AS number 5000
BGP table version is 1, main routing table version 1
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4  6000       0       0        0    0    0 never    Active

We see that the relationship will not form. You guys tell me why.

I’m attaching the .net file, with it and the configs above you should be able to replicate this easily.
The Troubleshooting Lab #1 .net file
(Don’t forget to change your paths)

Colby

Colby Glass has been in IT since 2002. He is currently a Systems Engineer (presales) with a Cisco Gold partner and holds the CCNP R/S, CCNP DC, CCDP, CCIP, JNCIA-ER.

More Posts